Corriger l’erreur http 503 après une mise à jour ESXi 5.x vers 6.0u2

MAJ 04/04/2016 : Un des ingénieurs de VMWare travaillant sur l’EHC m’a indiqué qu’une prochaine version du Host Client devrait corriger ce dysfonctionnement.
MAJ 11/05/2016 : l’erreur est désormais documentée chez VMWare sur ce KB#2144962

Après notre mise à jours récente de notre vCenter 5.5 en 6.0u2, c’est au tour de nos hyperviseurs ESXi d’être migrés très progressivement vers ESXi 6.0. Nous avons réalisé les premières upgrades « in place », via la Update Manager, sans grande difficulté d’ailleurs. Ceci étant, après cette opération, lors d’une tentative de connexion au nouvel outil ESXi Embedded Host client, intégré à la branche production après plusieurs mois sur Flings (j’en ai parlé à de nombreuses reprises…), on obtenait systématiquement une erreur « 503 » de ce type :

Après quelques recherches, j’ai trouvé un petit thread sur le forum communities de VMWare qui donne la solution. Il suffit de se connecter à l’ESXi sous SSH pour éditer le fichier endpoints.conf situé dans /etc/vmware/rhttpproxy/. Supprimez juste la ligne décrivant la fonction reverse proxy associée à l’URI « /ui ». Terminez par une relance du service reverse proxy de l’ESXi grâce à un petit /etc/init.d/rhttpproxy restart et cela devrait vous sauver :)

En fait, si vous creusez un peu, vous verrez que c’est spécifiquement documenté dans la fiche Embedded Host Client de Flings… comme toujours, RTFM !

Le thread sur les forums communautaires VMWare : https://communities.vmware.com/thread/532633?start=0&tstart=0